CDN Broker cannot create or update CDN distributions
Resolved
Hello,

We’ve resolved the issue that affected the GOV.UK PaaS cdn-route service, and full service has been restored.

The issue was caused by a change in the versions of the ACME API supported by our certificate authority (Letsencrypt). We've released an update to our service so it does not attempt to use unsupported API operations.

Due to an oversight, we were not subscribed to the mailing list which would have informed us of this change in advance. We've now ensured that we are subscribed, which should mean we can take action before this becomes a problem in future.

I’m sorry for the delays and confusion that this may have caused for your team.

The quickest way to get help using the platform is to email us via gov-uk-paas-support@digital.cabinet-office.gov.uk. To let us know how this incident has affected you, please contact the GOV.UK PaaS product manager: luke.malcher@digital.cabinet-office.gov.uk.

Regards,

Richard Towers
GOV.UK PaaS team
Posted Nov 25, 2019 - 13:49 GMT
Identified
Presently updates to the CDN broker which involve adding or removing new domain names will fail; we are working on an update to the broker to resolve the issue.

This only affects changing the creation of new CDN routes, and changing the configuration of existing CDN routes which involve the "domain" configuration parameter.

This does NOT affect traffic flowing through CDN routes.
Posted Nov 13, 2019 - 12:15 GMT
This incident affected: Ireland (CDN Route Backing service - availability of platform-provided services) and London (CDN Route Backing service - availability of platform-provided services).