IMPORTANT: Degraded performance of Autoscaler
Resolved
Hello,

We’ve resolved the issue that affected GOV.UK PaaS today, and full service has been restored to development and production applications running on the platform.

The Autoscaler component that we offer as part of the platform was exhibiting degraded service after upgrading the metrics server it uses to calculate when to perform scaling events. We have reverted back to the previous working version, we are working with the upstream component developers to aid in resolving the behaviour seen with this version. In the meantime, the Autoscaler will perform as it did before.

We're sorry if this had any impact on your users and the service you provide, and any problems this may have caused for your team.

Making sure GOV.UK PaaS is constantly available and robust is our priority and we’ll be doing everything we can to minimise the possibility of outage in the future.

The quickest way to get help using the platform is to email us via gov-uk-paas-support@digital.cabinet-office.gov.uk. To let us know how this incident has affected you, please contact the GOV.UK PaaS product manager: mark.buckley@digital.cabinet-office.gov.uk.

Regards,

Mark Buckley
GOV.UK PaaS team
Posted May 11, 2021 - 15:19 BST
Identified
Hello,

We are aware of and investigating a problem with GOV.UK PaaS involving degraded performance of the Autoscaler component.

We are aware of a fix and we are implementing this now and will update in due course.

We’re looking into this as a matter of urgency and will update you as soon as we know more.

Regards,

Mark Buckley
GOV.UK PaaS team
Posted May 11, 2021 - 10:59 BST
This incident affected: London (Autoscaler) and Ireland (Autoscaler).