Problem with using Docker images [P4]
Resolved
This incident has been resolved.
Posted May 25, 2018 - 10:19 BST
Update
Hello,

We are still working to resolve the problem with using Docker images on GOV.UK PaaS, where files deleted during the Docker build process are still visible in the filesystem, but any attempts to access the underlying file cause an error.

Since our last update, the upstream fix to the Cloud Foundry platform, has been released, and we are implementing an upgrade to resolve the problem.

If you are experiencing similar issues using Docker with your applications and you think it might be due to this issue, please contact us via gov-uk-paas-support@digital.cabinet-office.gov.uk and let us know.


We’ll let you know as soon as the problem has been resolved.


Regards,

Urmi Shah, Delivery Manager
GOV.UK PaaS team
Posted May 23, 2018 - 16:35 BST
Update
We are continuing to work on the problem with using Docker images on GOV.UK PaaS, where files deleted during the Docker build process are still visible in the filesystem, but any attempts to access the underlying file cause an error.

We are waiting for confirmation of when the upstream fix in the Cloud Foundry platform will be available. Once this is available in a release, we will apply it. We will update you as soon as we learn more.

If you are experiencing issues using Docker with your applications and you think it might be due to this issue, please contact us via gov-uk-paas-support@digital.cabinet-office.gov.uk and let us know.
Posted May 17, 2018 - 14:49 BST
Identified
Hello,

We have an update on the problem with using Docker images on GOV.UK PaaS, where files deleted during the Docker build process are still visible in the filesystem, but any attempts to access the underlying file cause an error.

There has been an upstream fix applied in the Cloud Foundry platform. Once this is available in a release, we will apply it. We will update you as soon as we learn more. We have downgraded this to a P4 issue as it not impacting any tenant apps or end users.

If you are experiencing issues using Docker with your applications and you think it might be due to this issue, please contact us via gov-uk-paas-support@digital.cabinet-office.gov.uk and let us know.


Regards,
Urmi Shah, Delivery Manager
The GOV.UK PaaS team
Posted May 16, 2018 - 10:58 BST
Investigating
Hello,

We are still working to resolve the problem with using Docker images on GOV.UK PaaS, where files deleted during the Docker build process are still visible in the filesystem, but any attempts to access the underlying file cause an error.

Since our last update, the upstream fix to the Cloud Foundry platform, has been identified, and is in progress.

If you are experiencing similar issues using Docker with your applications and you think it might be due to this issue, please contact us via gov-uk-paas-support@digital.cabinet-office.gov.uk and let us know.


We’ll continue to update you as we know more, and we’ll let you know as soon as the problem has been resolved.


Regards,

Urmi Shah, Delivery Manager
GOV.UK PaaS team
Posted May 15, 2018 - 10:35 BST
Identified
Hello,

We are aware of and are investigating a problem with using Docker images on GOV.UK PaaS. We have identified a regression in a component responsible for deploying Docker images to the platform. Some applications using Docker may be experiencing problems that affect end users.

Files deleted during the Docker build process are still visible in the filesystem, but any attempts to access the underlying file will cause an error.

If you are experiencing similar issues using Docker with your applications and you think it might be due to this issue, please contact us via gov-uk-paas-support@digital.cabinet-office.gov.uk and let us know.

To address this issue, we have documented the problem and are waiting for an upstream fix to the Cloud Foundry platform, which is in process. We will update you as soon as we learn more.

Regards,

The GOV.UK PaaS team
Posted May 14, 2018 - 12:17 BST